[Webkit-unassigned] [Bug 116049] Add a DisplayAndPowerController class to handle IOKit Display and Power notifications

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 14 01:39:29 PDT 2013


--- Comment #5 from Roger Fong <roger_fong at apple.com>  2013-05-14 01:37:55 PST ---
(In reply to comment #4)
> (In reply to comment #3)
> > > I’d call this PowerSavingController instead.
> > 
> > Hmm the display notification functionality is for power saving but the power notifications functionality is for shared timer stuff...plus I feel like the class can be used for more than just PowerSaving functionality in the future right?

True, although there's still the problem that currently the Power notifications aspect that is currently implemented is not used for Power Saving purposes.

> Looking at the implementation, why does DisplayAndPowerController need any variable at all? It seems like we should move everything to DisplayAndPowerControllerInternals and just expose initDisplayAndPowerController() instead.
> The controller doesn't have any API whatsoever.

I wanted to leave s_screenDimmed as a part of DisplayAndPowerController because I felt natural that a display controller should keep the current state of the display. In addition, FrameSelection.cpp will be calling isScreenDimmed() to determine whether or not to invalidate the caret rect. I suppose then that I could leave the implementation of isScreenDimmed up to the platform as well instead of just returning s_screenDimmed but that seems rather odd to me.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list