[Webkit-unassigned] [Bug 112886] [SH4] LLInt sh4 backend implementation

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 21 03:46:20 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=112886





--- Comment #6 from Julien Brianceau <jbrianceau at nds.com>  2013-03-21 03:48:46 PST ---
(In reply to comment #3)
> Other than that, please fix the two cases of unnecessary code duplication.  I can r+ once you do.
Done in the second patch.

> But I would kind of like to see this done in terms of risc.rb unless there is a strong reason not to.
I started to look at risc.rb and there are some things that I don't understand.

For instance the riscLowerSimpleBranchOps, where we have something like this:
  # baddiz foo, bar, baz
  #
  # will become:
  #
  # addi foo, bar
  # bz baz

As I see in the C loop impl, I thought it would be something like:
  # baddiz foo, bar, baz
  #
  # will become:
  #
  # addi foo, bar, tmp
  # bz baz
  # move tmp, bar

Am I missing something here ?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list