[Webkit-unassigned] [Bug 110375] Add client callbacks to notify of changes of associated form controls

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Mar 20 18:30:32 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=110375


Ryosuke Niwa <rniwa at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #194095|review?                     |review+
               Flag|                            |




--- Comment #93 from Ryosuke Niwa <rniwa at webkit.org>  2013-03-20 18:32:57 PST ---
(From update of attachment 194095)
View in context: https://bugs.webkit.org/attachment.cgi?id=194095&action=review

> Source/WebCore/dom/Document.cpp:6078
> +    if (!frame() || !frame()->page()
> +        || !frame()->page()->chrome()->client()->shouldNotifyOnFormChanges())

Why are you wrapping the line here? We can fit both lines in one line.

> Source/WebCore/dom/Document.cpp:6090
> +    HashSet<Element*> associatedFormControls;

Adding a blank line here will improve the readability.

> Source/WebCore/dom/Document.cpp:6094
> +    HashSet<Element*>::iterator controlsEnd = m_associatedFormControls.end();
> +    for (HashSet<Element*>::iterator it = m_associatedFormControls.begin(); it != controlsEnd; ++it)
> +        associatedFormControls.add(*it);
> +    frame()->page()->chrome()->client()->didAssociateFormControls(associatedFormControls);

Now I'm reading this code for the second time, I feel like we should just pass a Vector to didAssociateFormControls because
then we can use copyToVector in HashSet.h as opposed to manually iterating over them.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list