[Webkit-unassigned] [Bug 111670] Support bottom-right anchored fixed-position elements during a pinch gesture

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 19 10:44:48 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=111670





--- Comment #18 from Sami Kyöstilä <skyostil at chromium.org>  2013-03-19 10:47:12 PST ---
(From update of attachment 193683)
View in context: https://bugs.webkit.org/attachment.cgi?id=193683&action=review

> Source/WebCore/page/scrolling/chromium/ScrollingCoordinatorChromium.cpp:241
> +    if (layer && layer != except && scrollingWebLayerForGraphicsLayer(layer))

I think "scrollingWebLayerForGraphicsLayer" is a pretty misleading name (also true before your patch) because the returned layer may or may not have anything to do with scrolling -- it's just the platformLayer() we're interested in here and below. I don't think you should necessarily fix it in your patch, though.

> Source/WebCore/page/scrolling/chromium/ScrollingCoordinatorChromium.cpp:267
> +    // Avoid unnecessary commits

Thanks for explaining this. I'm on the fence about whether a simple if (backing->ancestorClippingLayer() != mainLayer) { ... } would be clearer but either way is fine by me.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list