[Webkit-unassigned] [Bug 112457] Determine background visibility at layout time

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 15 12:58:44 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=112457


Simon Fraser (smfr) <simon.fraser at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #193352|review?                     |review+
               Flag|                            |




--- Comment #2 from Simon Fraser (smfr) <simon.fraser at apple.com>  2013-03-15 13:01:10 PST ---
(From update of attachment 193352)
View in context: https://bugs.webkit.org/attachment.cgi?id=193352&action=review

> Source/WebCore/ChangeLog:8
> +        We can put more effort into this in layout time as there are less layouts than paints.

fewer layouts

> Source/WebCore/rendering/RenderBox.h:596
> +    virtual void determineIsBackgroundKnownToBeObscured();

Awkward name. Maybe updateBackgroundKnownToBeObscured() or computeBackgroundObscurity()

> Source/WebCore/rendering/RenderObject.h:691
> +    void setIsBackgroundKnownToBeObscured(bool b) { m_bitfields.setIsBackgroundKnownToBeObscured(b); }

Should be setBackgroundIsKnownToBeObscured

> Source/WebCore/rendering/RenderObject.h:1114
> +        ADD_BOOLEAN_BITFIELD(isBackgroundKnownToBeObscured, IsBackgroundKnownToBeObscured);

Member should be called backgroundIsKnownToBeObscured or just backgroundKnownToBeObscured

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list