[Webkit-unassigned] [Bug 112276] Allow multiple searchKeys to be passed to AXUIElementCopyParameterizedAttributeValue

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Mar 13 13:14:57 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=112276





--- Comment #5 from Greg Hughes <ghughes at apple.com>  2013-03-13 13:17:23 PST ---
(From update of attachment 192964)
View in context: https://bugs.webkit.org/attachment.cgi?id=192964&action=review

>> Source/WebCore/accessibility/AccessibilityObject.cpp:121
>> +    unsigned length = criteria->searchKeys->size();
> 
> my guess is that size() is a size_t object

fixed in next patch

>> Source/WebCore/accessibility/AccessibilityObject.cpp:124
>> +        switch (criteria->searchKeys->at(i)) {
> 
> all these changes here are unnecessary and they'll fail the style guidelines

fixed in next patch (also moved switch statement to is own function to make the loop easier to read)

>> Source/WebCore/accessibility/AccessibilityObject.cpp:125
>> +                // The AnyTypeSearchKey matches any non-null AccessibilityObject.
> 
> When wrapping a line, only indent 4 spaces.  [whitespace/indent] [3]

fixed in next patch

>> Source/WebCore/accessibility/AccessibilityObject.cpp:126
>> +            case AnyTypeSearchKey:
> 
> A case label should not be indented, but line up with its switch statement.  [whitespace/indent] [4]

fixed in next patch

>> Source/WebCore/accessibility/mac/WebAccessibilityObjectWrapperMac.mm:3187
>> +        if ([searchKeyEntry isKindOfClass:[NSString self]])
> 
> [NSString class]

fixed in next patch

>> Source/WebCore/accessibility/mac/WebAccessibilityObjectWrapperMac.mm:3189
>> +        else if ([searchKeyEntry isKindOfClass:[NSArray self]]) {
> 
> [NSArray class]

fixed in next patch

>> Source/WebCore/accessibility/mac/WebAccessibilityObjectWrapperMac.mm:3190
>> +            unsigned length = [(NSArray *)searchKeyEntry count];
> 
> i believe count is a NSUInteger

fixed in next patch (downcast to a size_t because reserveInitialCapacity takes a size_t)

>> Source/WebCore/accessibility/mac/WebAccessibilityObjectWrapperMac.mm:3192
>> +            for (unsigned i = 0; i < length; ++i) {
> 
> size length is NSUInteger, so should i

fixed in next patch (downcast to a size_t because reserveInitialCapacity takes a size_t)

>> Source/WebCore/accessibility/mac/WebAccessibilityObjectWrapperMac.mm:3194
>> +                if ([searchKey isKindOfClass:[NSString self]])
> 
> [NSString class]

fixed in next patch

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list