[Webkit-unassigned] [Bug 111919] Coordinated Graphics: Unify messages related object's lifecycles into CoordinatedGraphicsState.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Mar 10 16:56:55 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=111919





--- Comment #7 from Gwang Yoon Hwang <ryumiel at company100.net>  2013-03-10 16:59:19 PST ---
(In reply to comment #5)
> (From update of attachment 192355 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=192355&action=review
> 
> > Source/WebCore/platform/graphics/texmap/coordinated/CoordinatedImageBacking.h:77
> > -    Coordinator* m_coordinator;
> > +    Client* m_client;
> 
> These renames are OK but let's do them in a different patch.
> 
> > Source/WebCore/platform/graphics/texmap/coordinated/UpdateAtlas.cpp:33
> > -UpdateAtlas::UpdateAtlas(UpdateAtlasClient* client, int dimension, CoordinatedSurface::Flags flags)
> > +UpdateAtlas::UpdateAtlas(Client* client, int dimension, CoordinatedSurface::Flags flags)
> 
> Ditto. OK to do both renames in the same patch, but not in the same patch as the state unification, as it makes commit history harder to read.
> 

I got it. I'm sorry i've missed your previous comment.
I made separate refactoring bug for that
https://bugs.webkit.org/show_bug.cgi?id=111948


> > Source/WebKit2/WebProcess/WebPage/CoordinatedGraphics/CoordinatedLayerTreeHost.cpp:641
> > -bool CoordinatedLayerTreeHost::createUpdateAtlas(uint32_t atlasID, PassRefPtr<CoordinatedSurface> coordinatedSurface)
> > +void CoordinatedLayerTreeHost::createUpdateAtlas(uint32_t atlasID, PassRefPtr<CoordinatedSurface> surface)
> >  {
> > -    WebCoordinatedSurface* webCoordinatedSurface = static_cast<WebCoordinatedSurface*>(coordinatedSurface.get());
> > -    WebCoordinatedSurface::Handle handle;
> > -    if (!webCoordinatedSurface->createHandle(handle))
> > -        return false;
> > -    m_webPage->send(Messages::CoordinatedLayerTreeHostProxy::CreateUpdateAtlas(atlasID, handle));
> > -    return true;
> > +    m_state.updateAtlasesToCreate.append(std::make_pair(atlasID, surface));
> 
> This feels like a change in behavior that belongs in a different patch.

This is needed in this patch. Because this patch delays encoding of CoordinatedSurface message until flush timing, we cannot know whether it is success in this timing.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list