[Webkit-unassigned] [Bug 101857] Updating mouse cursor on style changes without emitting fake mousemove event

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Mar 6 09:30:42 PST 2013


Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
 Attachment #191721|review?                     |review+
               Flag|                            |

--- Comment #122 from Darin Adler <darin at apple.com>  2013-03-06 09:33:05 PST ---
(From update of attachment 191721)
View in context: https://bugs.webkit.org/attachment.cgi?id=191721&action=review

Seems OK. A few things that I still think need improvement, but good enough to land.

> Source/WebCore/page/EventHandler.cpp:1254
> +    bool shiftKey;
> +    bool ctrlKey;
> +    bool altKey;
> +    bool metaKey;
> +    PlatformKeyboardEvent::getCurrentModifierState(shiftKey, ctrlKey, altKey, metaKey);
> +
> +    HitTestRequest request(HitTestRequest::ReadOnly);
> +    HitTestResult result(view->windowToContents(m_lastKnownMousePosition));

As I mentioned in my previous comment, conceptually both mouse position changes and modifier key states come in to the event handler as a stream. It’s a mistake to pair a saved mouse position with a freshly obtained shift key state.

> Source/WebCore/page/EventHandler.cpp:1280
> +    bool originalIsText = node->isTextNode();

I think a better name would be originalNodeWasText.

> Source/WebCore/page/EventHandler.cpp:1282
> +    if (node && originalIsText)
> +        node = node->parentNode();

This call to parentNode is new code. Why does this change need to be made? Does it improve something?

> Source/WebCore/page/FrameView.h:343
> +    virtual bool shouldSetCursor() const;

Why virtual?

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list