[Webkit-unassigned] [Bug 109659] Coordinated Graphics : Prevent code duplication of CoordinatedSurface

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 15 03:57:04 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=109659


Noam Rosenthal <noam at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #188005|review?                     |review-
               Flag|                            |




--- Comment #2 from Noam Rosenthal <noam at webkit.org>  2013-03-15 03:59:29 PST ---
(From update of attachment 188005)
View in context: https://bugs.webkit.org/attachment.cgi?id=188005&action=review

> Source/WebCore/ChangeLog:3
> +        Coordinated Graphics : Prevent code duplication of CoordinatedSurface

Coordinated Graphics:

> Source/WebCore/ChangeLog:10
> +        This is patch moves CoordinatedSurface implementation that will be shared
> +        between WebKit1 CoordinatedSurface and WebCoordinatedSurface to
> +        CoordinatedSurface so that it prevents code duplication.

Move some of the duplicated code to CoordinatedSurface.

> Source/WebCore/platform/graphics/texmap/coordinated/CoordinatedSurface.cpp:64
> +PassRefPtr<GraphicsSurface> CoordinatedSurface::createGraphicsSurface(const IntSize& size, Flags flags)

createWithNewGraphicsSurface

> Source/WebCore/platform/graphics/texmap/coordinated/CoordinatedSurface.cpp:84
> +    RefPtr<BitmapTextureGL> textureGL = toBitmapTextureGL(texture);
> +    if (textureGL) {

You can't assume that textureMapper is GL based. You should only do this when isBackedByOpenGL returns true.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list