[Webkit-unassigned] [Bug 111591] [EFL][WK2] Separate WebView further from EwkView

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 14 06:40:25 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=111591


Caio Marcelo de Oliveira Filho <cmarcelo at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |cmarcelo at webkit.org




--- Comment #19 from Caio Marcelo de Oliveira Filho <cmarcelo at webkit.org>  2013-03-14 06:42:50 PST ---
It seems that when you use an EFL web view, you want it to be an EvasObject, so I think should be way more simpler to make the EFL API use the WKViewCreate by itself instead of making the calling code do that.

EFL API would expose a way to get the WKViewRef/WKPageRef in order to use other WK2 C API calls.

In this scenario we'll have:

- WKViewRef/WebView as the "raw" web view API. One can use WKViewCreate() to use them.
- ewk_view_*/EwkView as the EFL web view API. It uses WKViewCreate() itself, it exposes its WKViewRef and WKPageRef for sharing code in tests and places that make a "PlatformWebView" abstraction and use WK2 C API.

This approach avoids the (IMHO) confusing WKViewCreateEvasObject() function, that does a lot of stuff behind that name: sligthly change ownership expectation about WKView, should be called only once per WebView, change the WK2 clients by itself.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list