[Webkit-unassigned] [Bug 111919] Coordinated Graphics: Unify messages related object's lifecycles into CoordinatedGraphicsState.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Mar 10 08:43:38 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=111919





--- Comment #5 from Noam Rosenthal <noam at webkit.org>  2013-03-10 08:46:03 PST ---
(From update of attachment 192355)
View in context: https://bugs.webkit.org/attachment.cgi?id=192355&action=review

> Source/WebCore/platform/graphics/texmap/coordinated/CoordinatedImageBacking.h:77
> -    Coordinator* m_coordinator;
> +    Client* m_client;

These renames are OK but let's do them in a different patch.

> Source/WebCore/platform/graphics/texmap/coordinated/UpdateAtlas.cpp:33
> -UpdateAtlas::UpdateAtlas(UpdateAtlasClient* client, int dimension, CoordinatedSurface::Flags flags)
> +UpdateAtlas::UpdateAtlas(Client* client, int dimension, CoordinatedSurface::Flags flags)

Ditto. OK to do both renames in the same patch, but not in the same patch as the state unification, as it makes commit history harder to read.

> Source/WebKit2/WebProcess/WebPage/CoordinatedGraphics/CoordinatedLayerTreeHost.cpp:641
> -bool CoordinatedLayerTreeHost::createUpdateAtlas(uint32_t atlasID, PassRefPtr<CoordinatedSurface> coordinatedSurface)
> +void CoordinatedLayerTreeHost::createUpdateAtlas(uint32_t atlasID, PassRefPtr<CoordinatedSurface> surface)
>  {
> -    WebCoordinatedSurface* webCoordinatedSurface = static_cast<WebCoordinatedSurface*>(coordinatedSurface.get());
> -    WebCoordinatedSurface::Handle handle;
> -    if (!webCoordinatedSurface->createHandle(handle))
> -        return false;
> -    m_webPage->send(Messages::CoordinatedLayerTreeHostProxy::CreateUpdateAtlas(atlasID, handle));
> -    return true;
> +    m_state.updateAtlasesToCreate.append(std::make_pair(atlasID, surface));

This feels like a change in behavior that belongs in a different patch.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list