[Webkit-unassigned] [Bug 111636] New: RenderFullScreen should call setNeedsLayoutAndPrefWidthsRecalc on the child (?)

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Mar 6 15:44:06 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=111636

           Summary: RenderFullScreen should call
                    setNeedsLayoutAndPrefWidthsRecalc on the child (?)
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Layout and Rendering
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: cbiesinger at chromium.org
                CC: hyatt at apple.com, ojan at chromium.org,
                    jer.noble at apple.com


http://trac.webkit.org/browser/trunk/Source/WebCore/rendering/RenderFullScreen.cpp?rev=HEAD#L154

The code here looks like:
154            while ((child = firstChild())) {
155                child->remove();
156                parent()->addChild(child, this);
157                parent()->setNeedsLayoutAndPrefWidthsRecalc();
158            }

It seems to me like setNeedsLayoutAndPrefWidthsRecalc() should be called on the child (which then would recurse through the parents).

hyatt, does that seem plausible? At least, if it is right to call it on the parent, it should be outside the loop.

(I don't have a testcase either way, we found this by code inspection)

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list