[Webkit-unassigned] [Bug 111112] [chromium] Keydown event for 'shift+alt' returns win keycode instead of 'alt'

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 5 16:55:46 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=111112


Tony Chang <tony at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #191592|review?, commit-queue?      |review+, commit-queue-
               Flag|                            |




--- Comment #5 from Tony Chang <tony at chromium.org>  2013-03-05 16:58:11 PST ---
(From update of attachment 191592)
View in context: https://bugs.webkit.org/attachment.cgi?id=191592&action=review

Looks like you also need to rebase your patch to ToT.

> ManualTests/shift-alt-key-event.html:8
> +function myFunction(event)

Please use a better name than myFunction.  How about keyDown?

> ManualTests/shift-alt-key-event.html:14
> +    if(event.shiftKey == true && event.altKey == true && event.which == 18) {

Nit: Put a space after if.

> ManualTests/shift-alt-key-event.html:16
> +    }else {

Nit: Space between } and else.

> ManualTests/shift-alt-key-event.html:19
> +    output.innerHTML=text;

Nit: Spaces around =.

> ManualTests/shift-alt-key-event.html:25
> +<p>Test for <a href="http://bugs.webkit.org/show_bug.cgi?id=?????">bug ?????</a>:

Please fill in the bug number or just remove this text.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list