[Webkit-unassigned] [Bug 110291] Move WebCore feature defines to the WebCore directory

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 1 12:55:55 PST 2013


--- Comment #6 from David Kilzer (:ddkilzer) <ddkilzer at webkit.org>  2013-03-01 12:58:18 PST ---
(From update of attachment 189898)
View in context: https://bugs.webkit.org/attachment.cgi?id=189898&action=review

I like the general direction where this patch is going, but I'm hesitant to give the r+.  :)

Sam Weinig looked at this patch over my shoulder and he was okay with the direction as well.  (His only comment was about "FeatureDefines.h" sounding too generic, similar to my comment below.)

> Source/WebCore/FeatureDefines.h:30
> -#ifndef WTF_FeatureDefines_h
> -#define WTF_FeatureDefines_h
> +#ifndef FeatureDefines_h
> +#define FeatureDefines_h

What about naming this WebCoreFeatureDefines.h instead?  "FeatureDefines.h" is a bit generic, and if there are feature macros for JavaScriptCore (or WTF), I'd hate to have multiple "FeatureDefines.h" headers running around that were only differentiated by their path.

I also realize that would make the include be <WebCore/WebCoreFeatureDefines.h>, so I could go either way on this.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list