[Webkit-unassigned] [Bug 118179] [GTK] Refactor code for translating offsets between WebCore a11y and ATK

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 28 11:45:47 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=118179





--- Comment #2 from chris fleizach <cfleizach at apple.com>  2013-06-28 11:47:44 PST ---
(From update of attachment 205700)
View in context: https://bugs.webkit.org/attachment.cgi?id=205700&action=review

> Source/WebCore/accessibility/atk/WebKitAccessibleInterfaceText.cpp:473
> +static int listItemMarkerLengthForObject(const AccessibilityObject* object)

this only applies to LTR, maybe the method should be named to indicate that?

> Source/WebCore/accessibility/atk/WebKitAccessibleInterfaceText.cpp:475
> +    if (!object->isAccessibilityRenderObject())

you shouldn't have to check isAXRenderObject() -- renderer() is on every AXObject, so you just need to check if the renderer is 0 or not (which you're already doing)

> Source/WebCore/accessibility/atk/WebKitAccessibleInterfaceText.cpp:482
> +        String markerText = toRenderListItem(renderer)->markerTextWithSuffix();

this can be made into one line of code

> Source/WebCore/accessibility/atk/WebKitAccessibleInterfaceText.cpp:491
> +    if (!object->isAccessibilityRenderObject() || !object->isListItem())

AXrenderObject check is not necessary

> Source/WebCore/accessibility/atk/WebKitAccessibleInterfaceText.cpp:500
> +    if (!coreObject || !coreObject->isAccessibilityRenderObject() || !coreObject->isListItem())

AXRenderObject check not necessary

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list