[Webkit-unassigned] [Bug 117831] Develop rebase info tool for EWS

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 27 03:47:41 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=117831





--- Comment #3 from Csaba Osztrogonac <ossy at webkit.org>  2013-06-27 03:49:37 PST ---
(From update of attachment 205078)
View in context: https://bugs.webkit.org/attachment.cgi?id=205078&action=review

>> Tools/Scripts/webkitpy/tool/bot/earlywarningsystemtask.py:61
>> +        if self._delegate.run_tests:
>> +            return self._run_rebased_tests()
> 
> I don't think run_rebased_tests makes sense as "rebased" is an adjective.
> I would call it regenerate_expected_results instead.

I would make this change separated to the new "RunTestsFromPatch" command.
Additionally EWS bots should have three different option in ews.json:
- don't run tests at all (now: GTK, GTK-WK2, EFL, EFL-WK2, Qt, Qt-WK2)
- run only touched tests to help rebasing tasks (if they have limited hw resources)
- run all tests (if they have unlimited hw resources) (now: Win, Mac, Mac-WK2)

> Tools/Scripts/webkitpy/tool/commands/download.py:266
> +    help_text = "Get the list of rebased patches from patch and make new baselines for own"

I prefer the name run-tests-touched-by-attachment and help text:
"Run only tests touched by the given attachment"

> Tools/Scripts/webkitpy/tool/steps/forcetests.py:47
> +class ForceTests(AbstractStep):
> +    @classmethod
> +    def options(cls):
> +        return AbstractStep.options()
> +
> +    def run(self, state):
> +        self._options.test = True
> +        self._options.layout_testlist_only = True
> +        self._options.non_interactive = True

I don't like the idea to have a new ForceTests class to make
RunTestsFromPatch command really run tests independently of
--test command line option. Additionally it still doesn't 
build the attachment before trying to run the tests.

There are similar strangeness with many webkit-patch commands, for example:
- build-and-test doesn't build and doesn't test ... only if --build and --test command line options are passed
- build-attachment doesn't build ... only if --build passed
...

I prefer if AbstractPatchSequencingCommand would have 
_prepare_state function similar to AbstractSequencedCommand.

> Tools/Scripts/webkitpy/tool/steps/runtests.py:113
> +        if state["testlist"]:
> +            args.extend(state["testlist"])

What if the testlist is empty? In this case all tests 
would run, but we don't want to run any layout test.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list