[Webkit-unassigned] [Bug 117728] [EFL][WK2] Implement unit test callback: onSettingChange
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Jun 18 08:31:35 PDT 2013
https://bugs.webkit.org/show_bug.cgi?id=117728
--- Comment #12 from Christophe Dumez <dchris at gmail.com> 2013-06-18 08:30:12 PST ---
(From update of attachment 204914)
View in context: https://bugs.webkit.org/attachment.cgi?id=204914&action=review
>>> Source/WebKit2/UIProcess/API/efl/tests/test_ewk2_text_checker.cpp:279
>>> + EINA_LIST_FOREACH(contextMenuItems, listIterator, itemData) {
>>
>> Still looks like a lot of duplication with selectContextMenuOption(). How about renaming the utility function to findContextMenuItem() and call it twice?
>
> Sorry for inconvenience, method selectContextMenuOption() will be helpful in next test cases, when option will be selected directly from context menu.
but ewk_context_menu_item_select(contextMenu, findContextMenuItem(contextMenu, action, type)) does the same right? and findContextMenuItem() seems to be more reusable. alternatively you can keep selectContextMenuOption() and have it use findContextMenuItem(). I just want to get rid of the code duplication for iterating over the menu items.
>>> Source/WebKit2/UIProcess/API/efl/tests/test_ewk2_text_checker.cpp:288
>>> + ADD_FAILURE();
>>
>> ADD_FAILURE(); is non fatal. Why cannot we use FAIL() in a function returning a boolean?
>
> When I use FAIL() instead of ADD_FAILURE(), it returns en error at compile time:
> test_ewk2_text_checker.cpp:288:5: error: void value not ignored as it ought to be
ok.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list