[Webkit-unassigned] [Bug 117220] Allow for toggling fullscreen on <video> elements

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 7 14:59:33 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=117220





--- Comment #40 from Jon Lee <jonlee at apple.com>  2013-06-07 14:58:06 PST ---
(From update of attachment 204066)
View in context: https://bugs.webkit.org/attachment.cgi?id=204066&action=review

> Source/WebCore/ChangeLog:13
> +        without mac-specific changes to DumpRenderTree.

reference to bug?

> Source/WebCore/ChangeLog:23
> +        Updated to reame variables more appropriately to reflect the toggle-ability of video fullscreen.

sp: rename

> Source/WebCore/rendering/HitTestResult.cpp:407
> +        return mediaElement->isFullscreen();

I'd suggest containing the element within the var scope to reduce the code a bit, and improve readability:

if (HTMLMediaElement* mediaElement = this->mediaElement())
    return mediaElement->isVideo() && mediaElement->isFullscreen();

> Source/WebCore/rendering/HitTestResult.cpp:418
> +        HTMLVideoElement* videoElement = static_cast<HTMLVideoElement*>(mediaElement);

Is this local var necessary?

I think you can apply the above pattern here also.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list