[Webkit-unassigned] [Bug 115804] Avoid unnecessary data copies when loading subresources with DoNotBufferData option

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 7 11:44:24 PDT 2013


Carlos Garcia Campos <cgarcia at igalia.com> changed:

           What    |Removed                     |Added
 Attachment #203681|0                           |1
        is obsolete|                            |
 Attachment #204059|                            |review?
               Flag|                            |

--- Comment #37 from Carlos Garcia Campos <cgarcia at igalia.com>  2013-06-07 11:42:58 PST ---
Created an attachment (id=204059)
 --> (https://bugs.webkit.org/attachment.cgi?id=204059&action=review)
Updated patch

Patch rebased and updated to address review comments. In the end I got rid of the allDataReceived boolean parameter in CachedImage by refactoring the code a bit, since now we have different methods for incremental data chunks and finishLoading when all data has been received (and considering the multipart content case), I think it makes the code a bit easier to read.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list