[Webkit-unassigned] [Bug 104360] Coordinated Graphics: Separate LayerTreeCoordinator into LayerTreeCoordinator and CompositingCoordinator

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 7 05:03:48 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=104360





--- Comment #32 from Gwang Yoon Hwang <ryumiel at company100.net>  2013-06-07 05:02:21 PST ---
(In reply to comment #30)
> (From update of attachment 204012 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=204012&action=review
> 
> Sorry for the naming nitpicks... :)
> 
> > Source/WebCore/platform/graphics/texmap/coordinated/CompositingCoordinator.cpp:175
> > +    m_client->didSyncLayerState(state);
> 
> Actually maybe this should be called willSyncLayerState. Otherwise it's a bit puzzling when it changes the state...
> 
> > Source/WebCore/platform/graphics/texmap/coordinated/CompositingCoordinator.h:64
> > +        virtual void didSyncLayerState(CoordinatedGraphicsLayerState&) = 0;
> 
> willSyncLayerState. It's a bit puzzling to have "did" that modifies something...

Yes, I agree. Fixed.

> 
> > Source/WebCore/platform/graphics/texmap/coordinated/CompositingCoordinator.h:65
> > +        virtual void scheduleLayerFlushRequired() = 0;
> 
> notifyFlushRequired()
>

Ditto.

> > Source/WebCore/platform/graphics/texmap/coordinated/CompositingCoordinator.h:66
> > +        virtual void commitCoordinatedGraphicsState(CoordinatedGraphicsState&) = 0;
> 
> commitSceneState()
>

Ditto. 
> > Source/WebCore/platform/graphics/texmap/coordinated/CompositingCoordinator.h:67
> > +        virtual void paintContents(const GraphicsLayer*, GraphicsContext&, const IntRect& clipRect) = 0;
> 
> paintLayerContents
Ditto.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list