[Webkit-unassigned] [Bug 104360] Coordinated Graphics: Separate LayerTreeCoordinator into LayerTreeCoordinator and CompositingCoordinator

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 7 01:08:58 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=104360





--- Comment #29 from Gwang Yoon Hwang <ryumiel at company100.net>  2013-06-07 01:07:29 PST ---
(In reply to comment #27)
> (From update of attachment 203920 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=203920&action=review
> 
> > Source/WebCore/platform/graphics/texmap/coordinated/CompositingCoordinator.cpp:100
> > +    m_client->flushCompositingStatePeripheralLayers();
> 
> This should be called something like didFlushRootLayer(); The peripheral layers stuff should be known only to CoordinatedLTH.
> 
> > Source/WebCore/platform/graphics/texmap/coordinated/CompositingCoordinator.cpp:176
> > +    m_client->prepareCustomFilterProxiesIfNeeded(state);
> 
> This should be called didSyncLayerState. The client can decide whether this is about custom filters or something else.
> 

Yes, I love the way you suggests.

> 
> This client is too specific.
> The CompositingCoordinator::Client class should respond to events that compositing coordinator knows about, otherwise it looks like an artificial separation of classes...

 I made didFlushRootLayer and didSyncLayerState, and a Client(CoordinatedLTH) do what it need. 
I think that makes CompositingCoordinator::Client more generic.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list