[Webkit-unassigned] [Bug 99352] [GTK] [WebKit2] Add an 'authenticate' signal to WebKitWebView

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 31 03:22:24 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=99352





--- Comment #47 from Brian Holt <brian.holt at samsung.com>  2013-07-31 03:22:09 PST ---
(From update of attachment 207731)
View in context: https://bugs.webkit.org/attachment.cgi?id=207731&action=review

Thanks for the review!

>> Source/WebKit2/UIProcess/API/gtk/WebKitAuthenticationDialog.cpp:57
>>  }
> 
> I think we could destroy the dialog here, for consistency with the ok button approach. We can even get rid of the helper methods, since they are used only once in the callbacks.

Sounds good to me.

>> Source/WebKit2/UIProcess/API/gtk/WebKitAuthenticationRequest.cpp:126
>> + * Returns: (transfer full): A #WebKitCredential encapsulating credential details.
> 
> or %NULL if there isn't any previous credential saved. It's important to document this can return NULL.

Good point

>> Source/WebKit2/UIProcess/API/gtk/WebKitAuthenticationRequest.cpp:247
>> +guint webkit_authentication_request_get_previous_failures(WebKitAuthenticationRequest* request)
> 
> This returns the amount of previous failures, so I would call this either webkit_authentication_request_get_n_previous_failures or webkit_authentication_request_get_previous_failure_count.

Ok, I'll go for webkit_authentication_request_get_previous_failure_count since it ties in with the function that it calls

>> Source/WebKit2/UIProcess/API/gtk/WebKitCredential.cpp:70
>> +    return copy;
> 
> Maybe it would be simpler to simply return webkitCredentialCreate(credential->credential);

Good idea.

>> Source/WebKit2/UIProcess/API/gtk/WebKitCredential.h:63
>> +                                        const gchar                 *password,
> 
> Nit: the _new method is usually the first one, could you please move it?

Sure

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list