[Webkit-unassigned] [Bug 102586] [GTK] media/video-src-blob.html

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 17 10:46:09 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=102586





--- Comment #4 from Carlos Garcia Campos <cgarcia at igalia.com>  2013-07-17 10:46:06 PST ---
(In reply to comment #3)
> (From update of attachment 206897 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=206897&action=review
> 
> Looks good to me. Great work! Just a couple questions...

Thanks!

> > Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:465
> > +        DataBufferingPolicy bufferingPolicy = url.protocolIs("blob") ? BufferData : DoNotBufferData;
> > +        CachedResourceRequest cacheRequest(request, ResourceLoaderOptions(SendCallbacks, DoNotSniffContent, bufferingPolicy, DoNotAllowStoredCredentials, DoNotAskClientForCrossOriginCredentials, DoSecurityCheck, UseDefaultOriginRestrictionsForType));
> >          priv->resource = loader->requestRawResource(cacheRequest);
> 
> Why is it useful to buffer data that is already in memory on the client side?

Because when buffered it can be cached, I think. I followed what apple does, TBH.

> > Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:605
> > +    if (!url.isValid() || (!url.protocolIsInHTTPFamily() && !url.protocolIs("blob"))) {
> 
> I think this could be a helper. Something like urlIsValidAndHasSupportedProtocol or just urlHasSupportedProtocol.

I did it indeed :-) but in the end it looked too much code for a simple check and moved back to the current patch, I'll add the helper function since it makes the code easier to read.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list