[Webkit-unassigned] [Bug 99618] [MathML] Implement the mmultiscripts tag

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 30 13:35:14 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=99618





--- Comment #7 from chris fleizach <cfleizach at apple.com>  2013-07-30 13:35:00 PST ---
(From update of attachment 207760)
View in context: https://bugs.webkit.org/attachment.cgi?id=207760&action=review

> Source/WebCore/rendering/mathml/RenderMathMLScripts.cpp:156
> +    if (!beforeChild) {

this function should probably be broken up into smaller functions so it's a bit easier to digest

> Source/WebCore/rendering/mathml/RenderMathMLScripts.cpp:357
> +                for (RenderObject* child2 = child->nextSibling(); child2 && !child2->node()->hasTagName(MathMLNames::mprescriptsTag); child2 = child2->nextSibling()) {

i'd call this sibling rather than child2

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list