[Webkit-unassigned] [Bug 118185] Gmail reply email - Bold and Italic style get stuck

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 23 01:59:40 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=118185





--- Comment #10 from Ryosuke Niwa <rniwa at webkit.org>  2013-07-23 01:59:32 PST ---
(From update of attachment 207311)
View in context: https://bugs.webkit.org/attachment.cgi?id=207311&action=review

> LayoutTests/editing/style/toggle-style-bold-italic-mixed-editability.html:1
> +<html>

Missing DOCTYPE and we don't need to indent the test content like this. It's much less readable IMO.

> LayoutTests/editing/style/toggle-style-bold-italic-mixed-editability.html:21
> +                boldCommand();
> +                italicCommand();
> +                boldCommand();
> +                italicCommand();
> +                boldCommand();
> +                italicCommand();

You should call execBoldCommand and execItalicCommand so that the result of each execCommand will be logged.

> LayoutTests/editing/style/toggle-style-bold-italic.html:21
> +                selectAllCommand();
> +                boldCommand();
> +                italicCommand();
> +                boldCommand();
> +                italicCommand();
> +                boldCommand();
> +                italicCommand();

Ditto.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list