[Webkit-unassigned] [Bug 99065] [GStreamer] Add support for Media Source API

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 16 02:48:16 PDT 2013


--- Comment #13 from Philippe Normand <pnormand at igalia.com>  2013-07-16 02:48:33 PST ---
(From update of attachment 206381)
View in context: https://bugs.webkit.org/attachment.cgi?id=206381&action=review

> Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamer.cpp:192
> +        isValid &= gst_element_register(0, "webkitwebsrc", GST_RANK_PRIMARY + 100, WEBKIT_TYPE_WEB_SRC);

In which case the element would fail to be registered? Not sure this isValid variable is needed.

> Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamer.cpp:196
> +    srcFactory = gst_element_factory_find("webkitmediasrc");

I think srcFactory leaks here. Please use a GRefPtr like above

> Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamer.cpp:333
> +    if (!initializeGStreamerAndRegisterWebKitElements())

How about calling ::load(url) instead of copy/pasting code here?

> Source/WebCore/platform/graphics/gstreamer/MediaSourceGStreamer.cpp:56
> +MediaSourceGStreamer::AddStatus MediaSourceGStreamer::addSourceBuffer(const String& type, const CodecsArray& codecsArray, OwnPtr<SourceBufferPrivate>* sourceBufferPrivate)

Wow, an OwnPtr<>* ? First time I see that.

> Source/WebCore/platform/graphics/gstreamer/MediaSourceGStreamer.cpp:62
> +double MediaSourceGStreamer::duration()

This should be const I suppose :) Usually for one-line getters we define/implement directly in the header.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list