[Webkit-unassigned] [Bug 118716] New: [EFL][WK2] Relevant test classes should be redefined by inheriting from EWK2UnitTestBase as per each test file
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Jul 16 00:24:49 PDT 2013
https://bugs.webkit.org/show_bug.cgi?id=118716
Summary: [EFL][WK2] Relevant test classes should be redefined
by inheriting from EWK2UnitTestBase as per each test
file
Product: WebKit
Version: 528+ (Nightly build)
Platform: Other
OS/Version: Linux
Status: UNCONFIRMED
Severity: Normal
Priority: P2
Component: WebKit2
AssignedTo: webkit-unassigned at lists.webkit.org
ReportedBy: donggwan.kim at samsung.com
All the test files use EWK2UnitTestBase only.
There are many methods and variables defined in each test file as static.
It should be defined as relevant test class specific to each test file for more readability like below.
class EWK2FooTest : public EWK2UnitTestBase {
public:
void foo();
};
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list