[Webkit-unassigned] [Bug 117631] [GTK] Provide search functionality to MiniBrowser

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 15 08:30:54 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=117631





--- Comment #10 from Andres Gomez Garcia <agomez at igalia.com>  2013-07-15 08:31:46 PST ---
(In reply to comment #9)
> > Tools/MiniBrowser/gtk/BrowserSearchBar.c:60
> > +static void searchEntryIconReleasedCallback(BrowserSearchBar *searchBar)
> 
> I would call this searchEntryClearIconReleasedCallback to make more obvious this is the callback of the clear icon.

I've added now the primary icon so I've kept the callback name.

> > Tools/MiniBrowser/gtk/BrowserSearchBar.c:146
> > +
> 
> There's an extra line here.

Corrected.

> > Tools/MiniBrowser/gtk/BrowserSearchBar.h:52
> > +void browser_search_bar_search_next(BrowserSearchBar *);
> > +void browser_search_bar_search_previous(BrowserSearchBar *);
> 
> These are not used outside BrowserSearchBar, make them private.

Done.

> > Tools/MiniBrowser/gtk/BrowserWindow.c:310
> > +    browser_search_bar_close(BROWSER_SEARCH_BAR((window->searchBar)));
> 
> Extra parentheses there. BROWSER_SEARCH_BAR((
> 
> > Tools/MiniBrowser/gtk/BrowserWindow.c:324
> > +        browser_search_bar_open(BROWSER_SEARCH_BAR((window->searchBar)));
> 
> And here too

Done.

> > Tools/MiniBrowser/gtk/BrowserWindow.c:583
> > +    window->searchBarVisible = FALSE;
> 
> You don't need this, this is already FALSE at this point.

Done.

> > Tools/MiniBrowser/gtk/BrowserWindow.c:627
> > +    window->searchBar = GTK_WIDGET(browser_search_bar_new(window->webView));
> 
> browser_search_bar_new returns a GtkWidget *, you don't need the cast.

Done.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list