[Webkit-unassigned] [Bug 117834] [ATK] Adds support for aria-haspopup property.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 9 16:21:34 PDT 2013


--- Comment #15 from Krzysztof Czech <k.czech at samsung.com>  2013-07-09 16:23:34 PST ---
> > Tools/DumpRenderTree/atk/AccessibilityUIElementAtk.cpp:319
> > +static String attributeSetValueById(AtkAttributeSet* attributeSet, const String& id)
> this method seems like it should be named attributeValueForId after reading through what it does

Yes, you are right, that sounds more accurate.

> > Tools/DumpRenderTree/atk/AccessibilityUIElementAtk.cpp:326
> > +            attributeValue.set(g_strdup(attribute->value));
> Do you need to copy this to a GOwnPtr, or can you just return directly from here
> with return String(g_strdup(attribute->value))

I cannot directly return, I must clear AtkAttributeSet first.

> you probably want to do an equalIgnoringCase in case someone does aria-haspop=True

Yes, you are right

Thanks, applied all suggestions.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list