[Webkit-unassigned] [Bug 117834] [ATK] Adds support for aria-haspopup property.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 9 08:51:21 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=117834





--- Comment #12 from chris fleizach <cfleizach at apple.com>  2013-07-09 08:53:22 PST ---
(From update of attachment 205982)
View in context: https://bugs.webkit.org/attachment.cgi?id=205982&action=review

> Tools/DumpRenderTree/atk/AccessibilityUIElementAtk.cpp:41
> +static void attributesClear(AtkAttributeSet* attributesSet)

this method should probably be named "clearAttributes()"

> Tools/DumpRenderTree/atk/AccessibilityUIElementAtk.cpp:319
> +static String attributeSetValueById(AtkAttributeSet* attributeSet, const String& id)

this method seems like it should be named attributeValueForId after reading through what it does

> Tools/DumpRenderTree/atk/AccessibilityUIElementAtk.cpp:326
> +            attributeValue.set(g_strdup(attribute->value));

Do you need to copy this to a GOwnPtr, or can you just return directly from here

with return String(g_strdup(attribute->value))

> Tools/DumpRenderTree/atk/AccessibilityUIElementAtk.cpp:1038
> +    return attributeSetValueById(atk_object_get_attributes(ATK_OBJECT(m_element)), "aria-haspopup") == "true";

you probably want to do an equalIgnoringCase in case someone does aria-haspop=True

> Tools/WebKitTestRunner/InjectedBundle/atk/AccessibilityUIElementAtk.cpp:83
> +static String attributeSetValueById(AtkAttributeSet* attributeSet, const String& id)

ditto

> Tools/WebKitTestRunner/InjectedBundle/atk/AccessibilityUIElementAtk.cpp:1093
> +    return attributeSetValueById(atk_object_get_attributes(ATK_OBJECT(m_element.get())), "aria-haspopup") == "true";

ditto

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list