[Webkit-unassigned] [Bug 117543] [GTK] Merge decamelizations fix ups in the GObject DOM bindings code generator

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 2 04:15:15 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=117543





--- Comment #4 from Diego Pino <dpino at igalia.com>  2013-07-02 04:17:13 PST ---
Since this patch changes several parts of the code and it's hard to follow how those changes will affect the code generated, Xan suggested me to compare all the files under "WebKitBuild/Release/DerivedSources/webkitdom/" in branch master and a branch with this patch applied.

I wrote a script to do that (http://pastebin.com/T14kWZpF). The script revealed the following files were different:

   * WebKitBuild/Release/DerivedSources/webkitdom/WebKitDOMWebKitNamedFlow.cpp
   * WebKitBuild/Release/DerivedSources/webkitdom/WebKitDOMWebKitPoint.cpp
   * WebKitBuild/Release/DerivedSources/webkitdom/WebKitDOMHTMLIFrameElement.cpp
   * WebKitBuild/Release/DerivedSources/webkitdom/WebKitDOMXPathResult.cpp

The differences are due to an impromper decamelization of the variable "$nick" in master. Take for instance the file WebKitDOMHTMLIFrameElement.cpp, you can see code like this:

g_object_class_install_property(gobjectClass,
                                    PROP_ALIGN,
                                    g_param_spec_string("align", /* name */
                                                           "htmli_frame_element_align", /* short description */
                                                           "read-write  gchar* HTMLIFrameElement.align", /* longer - could do with some extra doc stuff here */
                                                           "", /* default */
                                                           WEBKIT_PARAM_READWRITE));

The string "htmli_frame_element_align" (value of the variable $nick), is not properly decamelized, it should be "html_iframe_element_align". This patch solves that unnoticed error too \o/

Besides "htmli", there are also an improper decamelization of the strings (as value of variable $nick) : 

   * "web_kit" should be "webkit"
   * "x_path" shouldb be "xpath"

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list