[Webkit-unassigned] [Bug 117868] Texture unit code refactoring

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 1 03:04:23 PDT 2013


--- Comment #13 from Christophe Dumez <dchris at gmail.com>  2013-07-01 03:06:20 PST ---
(From update of attachment 205791)
View in context: https://bugs.webkit.org/attachment.cgi?id=205791&action=review

> Source/WebCore/html/canvas/WebGLRenderingContext.h:455
>      Vector<TextureUnitState> m_textureUnits;

My proposal was not to make TextureUnitState a class but to get rid of TextureUnitState altogether. Then we could have the  following member:
Vector<RefPtr<WebGLTexture> > m_textureUnits;

Would that make sense? Noam should confirm but this is how I interpreted his comment.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list