[Webkit-unassigned] [Bug 91440] Implement 'vmin' and 'vmax' from CSS3 values and units

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 28 10:09:40 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=91440





--- Comment #4 from Tony Chang <tony at chromium.org>  2013-01-28 10:11:38 PST ---
(From update of attachment 184907)
View in context: https://bugs.webkit.org/attachment.cgi?id=184907&action=review

This looks fine to me, but it would be nice if Antti or Kling could take a look.

>>> Source/WebCore/css/CSSParser.cpp:1642
>>> +           || (value->unit >= CSSPrimitiveValue::CSS_VW && value->unit <= CSSPrimitiveValue::CSS_VMAX)
>> 
>> Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]
> 
> Should I fix this?

I would since you're here.  I suggested the same on the ch unit bug.

>> Source/WebCore/css/CSSPrimitiveValue.h:98
>> +        CSS_VMAX = 29,
> 
> enum members should use InterCaps with an initial capital letter.  [readability/enum_casing] [4]

This someone needs to fix as a separate refactor patch.

> Source/WebCore/css/CSSPrimitiveValue.idl:52
>      const unsigned short CSS_VW         = 26;
>      const unsigned short CSS_VH         = 27;
>      const unsigned short CSS_VMIN       = 28;
> +    const unsigned short CSS_VMAX       = 29;

Do these values need to be kept in sync with the enum in CSSPrimitiveValue.h?  If so, can we add a COMPILE_ASSERT to enforce it?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list