[Webkit-unassigned] [Bug 107829] Web Inspector: support JavaScript variable mutation in protocol and V8 bindings

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 24 09:06:41 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=107829





--- Comment #4 from Andrey Adaikin <aandrey at chromium.org>  2013-01-24 09:08:35 PST ---
(From update of attachment 184509)
View in context: https://bugs.webkit.org/attachment.cgi?id=184509&action=review

> Source/WebCore/inspector/InjectedScript.cpp:119
> +void InjectedScript::setVariableValue(ErrorString* errorString, const ScriptValue& callFrames, const String* callFrameOpt, const String* functionObjectIdOpt, int scopeNumber, const String& variableName, const String& newValueStr)

callFrameOpt -> callFrameIdOpt

> Source/WebCore/inspector/InjectedScriptSource.js:585
> +     * @param {*} newValue, unmasked custom value.

@param {RuntimeAgent.CallArgument} newValue? or is it just a {string} here?

> Source/WebCore/inspector/InjectedScriptSource.js:586
> +     * @return {*}

@return {string|undefined}

> Source/WebCore/inspector/InjectedScriptSource.js:595
> +            setter = function(scopeIndex, variableName, newValue) {

IMO, inlined try-catch blocks would look much more readable. One-liner code dup saver of the "Failed..." string does nor worth it.

> Source/WebCore/inspector/Inspector.json:2845
> +                    { "name": "callFrame", "$ref": "CallFrameId", "optional": true, "description": "Id of callframe that holds variable" },

name it "callFrameId"?

> Source/WebCore/inspector/Inspector.json:2849
> +                    { "name": "newValue", "$ref": "Runtime.CallArgument", "description": "New variable value" }

dots at the end of descriptions are missing

> Source/WebCore/inspector/InspectorDebuggerAgent.cpp:587
> +        injectedScript = m_injectedScriptManager->injectedScriptForObjectId(*callFrame);

callFrame -> callFrameId

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list