[Webkit-unassigned] [Bug 107364] Improve PageVisibility API with enums

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 23 16:07:10 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=107364





--- Comment #2 from David Kilzer (:ddkilzer) <ddkilzer at webkit.org>  2013-01-23 16:09:03 PST ---
(From update of attachment 183858)
View in context: https://bugs.webkit.org/attachment.cgi?id=183858&action=review

This looks good from an overall perspective, but I'd like a WebKit2 engineer to take a look to make sure some assumptions aren't being violated.

> Tools/TestWebKitAPI/Tests/WebKit2/PageVisibilityState.cpp:41
> +static void didRunJavaScript1(WKSerializedScriptValueRef, WKErrorRef, void*);
> +static void didRunJavaScript2(WKSerializedScriptValueRef, WKErrorRef, void*);
> +static void didRunJavaScript3(WKSerializedScriptValueRef, WKErrorRef, void*);
> +static void didRunJavaScript4(WKSerializedScriptValueRef, WKErrorRef, void*);

Can we come up with a better name for these methods that are more descriptive?  Maybe:

didRunStep1StateChangeVisibleToHidden
didRunStep2StateChangeHiddenToPrerender
didRunStep3StateChangePrerenderToPreview
didRunStep4InStatePreview

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list