[Webkit-unassigned] [Bug 107131] [GTK] Implement testRunner::setTextDirection

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 18 08:50:30 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=107131





--- Comment #13 from Martin Robinson <mrobinson at webkit.org>  2013-01-18 08:52:17 PST ---
(In reply to comment #11)
> (In reply to comment #10)
> > (From update of attachment 183459 [details] [details])
> > View in context: https://bugs.webkit.org/attachment.cgi?id=183459&action=review
> > 
> > > Source/WebKit/gtk/webkit/webkitwebview.cpp:5367
> > > +void webkit_web_view_direction_changed(WebKitWebView* webView, GtkTextDirection, gpointer)
> > 
> > Okay. One nit here is that this function doesn't follow WebKit naming conventions (we started doing that always at some point). I can fix that and land this.
> 
> I can fix it and provide a new patch but I'd like to be sure.
> 
> Then should I use the following style in the header:
> static void webkit_web_view_direction_changed(WebKitWebView* webView, GtkTextDirection previousDirection, gpointer data);
> 
> And in the implementation:
> void webkit_web_view_direction_changed(WebKitWebView* webView, GtkTextDirection previousDirecton, gpointer data);

Essentially if the function is in the public API it would be called:
In the c++ file: webkit_web_view_direction_changed(WebkItWebView* webView, GtkTextDirection previousDirection, gpointer data);
In the header: webkit_web_view_direction_changed(WebkItWebView* web_view, GtkTextDirection previous_direction, gpointer data);

If the function is only used internally it should be called:
webkitWebViewDirectionChanged(WebkItWebView* webView, GtkTextDirection previousDirection, gpointer data);

The reason the name changes is that we try to follow WebKit function naming style wherever we can. The naming scheme of GObject APIs is not something we can change. The reason that the parameter names change in public headers is to make gtkdoc happy. It's a bit convoluted. :(

> > > LayoutTests/platform/gtk-wk2/TestExpectations:-507
> > >  Bug(GTK) fast/events/clear-edit-drag-state.html [ Pass ]
> > >  Bug(GTK) fast/events/dont-loose-last-event.html [ Pass ]
> > >  Bug(GTK) fast/events/drag-selects-image.html [ Pass ]
> > >  Bug(GTK) fast/forms/text-input-event.html [ Pass ]
> > > -Bug(GTK) fast/html/set-text-direction.html [ Pass ]
> > 
> > How is the WebKit2 test passing now? Source/WebKit/gtk/webkit/webkitwebview.cpp is only used for WebKit1.
> 
> This patch was already passing in WebKit2, it was in the section "Tests working in WK2 and failing in WK1". That's the reason why I unflagged it in both TestExpection files for WK1 and WK2.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list