[Webkit-unassigned] [Bug 106212] INPUT_MULTIPLE_FIELDS_UI: Step-up/-down of month/day field should respect min/max attributes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 7 21:50:15 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=106212


Kent Tamura <tkent at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #181631|review?, commit-queue?      |review+, commit-queue-
               Flag|                            |




--- Comment #6 from Kent Tamura <tkent at chromium.org>  2013-01-07 21:52:10 PST ---
(From update of attachment 181631)
View in context: https://bugs.webkit.org/attachment.cgi?id=181631&action=review

> Source/WebCore/html/shadow/DateTimeEditElement.cpp:200
> +            const Vector<String>& labels = fieldType == DateTimeFormat::FieldTypeMonth
> +                ? (count == countForFullMonth
> +                    ? m_parameters.locale.monthLabels()
> +                    : m_parameters.locale.shortMonthLabels())
> +                : (count == countForFullMonth
> +                    ? m_parameters.locale.standAloneMonthLabels()
> +                    : m_parameters.locale.shortStandAloneMonthLabels());

Nested  conditional operators are not good for code readability.
I recommend not merge count==countForFullMonth case and count==countForNarrow/AbbreviatedMonth case.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list