[Webkit-unassigned] [Bug 99842] Touch operation corrupts screen when specifying other than overflow:visible in css

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 16 13:43:38 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=99842


Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #172286|commit-queue?, review?      |commit-queue-, review-
               Flag|                            |




--- Comment #4 from Darin Adler <darin at apple.com>  2013-01-16 13:45:24 PST ---
(From update of attachment 172286)
View in context: https://bugs.webkit.org/attachment.cgi?id=172286&action=review

Change is probably OK, but bug fixes like this need a ChangeLog before they can be reviewed and landed.

> Source/WebCore/platform/graphics/win/GraphicsContextCairoWin.cpp:1665
>          // We negate here since panning up moves the content up, but moves the scrollbar down.

Not the fault of this patch, but this code is in the complete wrong place. It’s inappropriate for panning code that makes use of nodes, renderers, and such to be in the platform layer, which is a separate subsystem that is lower level. GraphicsContextCairoWin.cpp is a crazy place for this code, and this code must be deleted or moved ASAP.

Longer term we may even move the platform code to a separate library, and code like this would not even be something you could compile.

> Source/WebCore/platform/graphics/win/GraphicsContextCairoWin.cpp:1666
> +        m_gestureTargetNode->renderer()->enclosingLayer()->scrollByRecursively(IntSize(-deltaX, -deltaY), WebCore::RenderLayer::ScrollOffsetClamping::ScrollOffsetClamped);

Should not need the WebCore:: prefix for code inside WebCore.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list