[Webkit-unassigned] [Bug 110415] Provide WKView SPI to defer telling the WebPageProxy and WebProcess about changes in the hosting window

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Feb 20 19:47:06 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=110415


Simon Fraser (smfr) <simon.fraser at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #189444|review?                     |review+
               Flag|                            |




--- Comment #4 from Simon Fraser (smfr) <simon.fraser at apple.com>  2013-02-20 19:49:29 PST ---
(From update of attachment 189444)
View in context: https://bugs.webkit.org/attachment.cgi?id=189444&action=review

> Source/WebKit2/UIProcess/API/mac/WKView.mm:213
> +    BOOL _windowChangeWasDeferred;

Want to rename this to 'viewInWindowChangeWasDeferred'?

> Source/WebKit2/UIProcess/API/mac/WKView.mm:3306
> +    if (!(--_data->_viewInWindowChangesDeferredCount) && _data->_windowChangeWasDeferred) {

Would be clearer to just hoist the --_data->_viewInWindowChangesDeferredCount outside the condition.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list