[Webkit-unassigned] [Bug 110190] [GTK] Move the API to get TLS certificate from WebKitURIResponse to WebKitWebView

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 19 08:20:45 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=110190


Martin Robinson <mrobinson at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #189019|                            |review?
               Flag|                            |




--- Comment #6 from Martin Robinson <mrobinson at webkit.org>  2013-02-19 08:23:06 PST ---
(From update of attachment 189019)
View in context: https://bugs.webkit.org/attachment.cgi?id=189019&action=review

Looks good to me as well. This will need an owner's review.

> Source/WebKit2/UIProcess/API/gtk/WebKitWebView.cpp:2896
> + * @certificate: (out) (transfer none): return location for a #GTlsCertificate
> + * @errors: (out): return location for a #GTlsCertificateFlags the verification status of @certificate

Is there an equivalent to "allow none" for out parameters or is it just assumed?

>>> Source/WebKit2/UIProcess/API/gtk/WebKitWebView.cpp:2907
>>> + *    from the server, or %FALSE otherwise.
>> 
>> I believe you can drop this 'or', it's made redundant by 'otherwise'.
> 
> I think martin insisted in adding that 'or', but I'm not sure, I'm not English expert :-P

I think the 'or' is fine.

> Source/WebKit2/UIProcess/API/gtk/tests/TestSSL.cpp:51
>          GTlsCertificate* certificate = 0;
> -        webkit_uri_response_get_https_status(response, &certificate, &m_tlsErrors);
> +        webkit_web_view_get_tls_info(m_webView, &certificate, &m_tlsErrors);
>          m_certificate = certificate;

Why not just use &m_certificate here?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list