[Webkit-unassigned] [Bug 108960] [GTK] Remove subresource leaks from WebKit1 and WebKit2

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 14 16:31:55 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=108960





--- Comment #27 from Gustavo Noronha (kov) <gns at gnome.org>  2013-02-14 16:34:12 PST ---
(From update of attachment 188402)
View in context: https://bugs.webkit.org/attachment.cgi?id=188402&action=review

> Source/WebKit/gtk/webkit/webkitwebview.cpp:5115
> +    GList* subResources = (GList*)data;
> +    g_list_foreach(subResources, (GFunc) g_object_unref, NULL);
> +    g_list_free(subResources);

These should use C++-style casts.

> Source/WebKit/gtk/webkit/webkitwebview.cpp:5123
> +    GList* subResources = 0;
> +    Vector<PassRefPtr<ArchiveResource> > subresources;

Maybe use subResources and coreSubResources, so it's easier to read, but otherwise I don't see a problem with this approach, even though there is an expectation being broken, I don't think anyone uses it so...

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list