[Webkit-unassigned] [Bug 107444] Add error checking into OpenCL version of SVG filters.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 12 00:23:58 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=107444


Zoltan Herczeg <zherczeg at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #187595|review?, commit-queue?      |review-, commit-queue-
               Flag|                            |




--- Comment #16 from Zoltan Herczeg <zherczeg at webkit.org>  2013-02-12 00:26:10 PST ---
(From update of attachment 187595)
Now we are quite close! Only a few more comments:

View in context: https://bugs.webkit.org/attachment.cgi?id=187595&action=review

> Source/WebCore/platform/graphics/filters/FilterEffect.cpp:284
> +    int errorCode = 0;

Do we really need this variable?

> Source/WebCore/platform/graphics/filters/FilterEffect.cpp:293
> +    errorCode = clFinish(context->commandQueue());
> +    if (context->isFailed(errorCode))
> +        return 0;

This could be combined into one check, without the errorCode.

> Source/WebCore/platform/graphics/gpu/opencl/FilterContextOpenCL.cpp:163
> +    if (m_transformColorSpaceWasCompiled)
> +        return true;

This is incorrect. m_transformColorSpaceWasCompiled can be true, even if there is an error.

> Source/WebCore/platform/graphics/gpu/opencl/FilterContextOpenCL.cpp:166
> +    if (inError())
> +        return false;

I think this is the correct form:

if (m_transformColorSpaceWasCompiled || inError())
    return !inError();

> Source/WebCore/platform/graphics/gpu/opencl/FilterContextOpenCL.cpp:240
>      errorNumber = clBuildProgram(program, 0, 0, 0, 0, 0);

Same as above. This variable seems unnecessary.

> Source/WebCore/platform/graphics/gpu/opencl/FilterContextOpenCL.h:75
> +    inline bool resourceAllocationIsFailed(bool);

I am thinking about this name for some time. Perhaps isResourceAllocationFailed a better name...

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list