[Webkit-unassigned] [Bug 108088] [GStreamer] webkitwebsrc is exposed to application-side

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 1 09:52:37 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=108088


Martin Robinson <mrobinson at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #186069|review?                     |review+, commit-queue-
               Flag|                            |




--- Comment #13 from Martin Robinson <mrobinson at webkit.org>  2013-02-01 09:54:38 PST ---
(From update of attachment 186069)
View in context: https://bugs.webkit.org/attachment.cgi?id=186069&action=review

Thanks!

> Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamer.cpp:343
> +    // Clean out everything after file:// url path.
> +    if (kurl.isLocalFile())
> +        kurl.removeFragmentIdentifier();

Mind moving this into MediaPlayerPrivateGStreamer::setPlaybinURL?

> Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamer.h:142
> +            static KURL getPlaybinURL(const gchar* uri);

Probably should be called convertPlaybinURL since it's not a getter.

> Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:596
> -    static gchar* protocols[] = {(gchar*) "http", (gchar*) "https", 0 };
> +    static gchar* protocols[] = {"webkit+http", "webkit+https", 0 };

I guess you need  const here?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list