[Webkit-unassigned] [Bug 110146] New: Rename AncestorChainWalker

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 18 12:01:10 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=110146

           Summary: Rename AncestorChainWalker
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: HTML DOM
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: rniwa at webkit.org
                CC: andersca at apple.com, koivisto at iki.fi,
                    dglazkov at chromium.org, morrita at google.com


AncestorChainWalker walker(node);
walker.parent();
return walker.get();

It's not obvious that the above code should behave differently from:

return node ? node->parentNode() : 0;

The class name should communicate the semantic difference.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list