[Webkit-unassigned] [Bug 109560] Implement coordinated scrollbar for subframes and sublayers

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Feb 16 08:14:15 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=109560





--- Comment #21 from Antonio Gomes <tonikitoo at webkit.org>  2013-02-16 08:16:32 PST ---
(From update of attachment 188658)
View in context: https://bugs.webkit.org/attachment.cgi?id=188658&action=review

It looks to me that removing the ScrollCoordinatorChromiumPrivate makes the patch harder to follow.

> Source/WebCore/page/FrameView.cpp:256
> +        if (m_frame->page())
> +            if (ScrollingCoordinator* scrollingCoordinator = m_frame->page()->scrollingCoordinator())
> +                scrollingCoordinator->willDestroyScrollableArea(this);

needs wrapping {}

> Source/WebCore/page/FrameView.cpp:320
> +    // FIXME: Technically the FrameView is not destroyed yet,
> +    // but this is our last chance to access ScrollingCoordinator.
> +    if (m_frame && m_frame->page())
> +        if (ScrollingCoordinator* scrollingCoordinator = m_frame->page()->scrollingCoordinator())
> +            scrollingCoordinator->willDestroyScrollableArea(this);
> +

It looks strange to have this block here and at the dtor.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list