[Webkit-unassigned] [Bug 108132] Refactor the way HAVE_XXX macros are set

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Feb 10 14:00:24 PST 2013


--- Comment #14 from Laszlo Gombos <laszlo.gombos at webkit.org>  2013-02-10 14:02:35 PST ---
(In reply to comment #6)
> (From update of attachment 186709 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=186709&action=review

Thanks for the review Benjamin !

> It is probably better to avoid OS(IOS) until Dave decided the fate of PLATFORM(MAC) and PLATFORM(IOS).

Ok, will do. For future discussions, I though we have consensus on preferring OS() macros over PLATFORM() macros in general.

> This?
> or 
> Having DARWIN and __MAC_OS_X_VERSION_MIN_REQUIRED together is not adding readability because iOS is also a Darwin system.

(__MAC_OS_X_VERSION_MIN_REQUIRED >= 1060) test needs either an OS(DARWIN) or a PLATFORM(MAC) guard around, otherwise the build fails on e.g. Qt Linux port because __MAC_OS_X_VERSION_MIN_REQUIRED is undefined.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list