[Webkit-unassigned] [Bug 109065] [v8] move persistent::new and ::dispose into same class

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Feb 6 13:27:25 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=109065


Adam Barth <abarth at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #186875|review?                     |review+, commit-queue-
               Flag|                            |




--- Comment #8 from Adam Barth <abarth at webkit.org>  2013-02-06 13:29:33 PST ---
(From update of attachment 186875)
View in context: https://bugs.webkit.org/attachment.cgi?id=186875&action=review

Generally this patch looks fine.  I would prefer if the associateObjectWithWrapper didn't have a raw boolean parameter though.  Either an enum or a WrapperConfiguration seems better.

> Source/WebCore/bindings/v8/ScriptWrappable.h:47
> +        if (!m_maskedWrapper.IsEmpty())
> +            CRASH();

This part of the patch seems separable from the rest of this work.  Perhaps we should make this change in a separate patch?

> Source/WebCore/bindings/v8/ScriptWrappable.h:79
>      v8::Persistent<v8::Object> m_maskedWrapper;

Aside from the masking, it seems like we could use a ScopedPersistent here.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list