[Webkit-unassigned] [Bug 106989] Get WebKit projects compiling in VS2010 (32 bit)

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 4 18:13:42 PST 2013


--- Comment #13 from Roger Fong <roger_fong at apple.com>  2013-02-04 18:15:47 PST ---
It would appear that the WebKitExportGenerator does not work in release mode.
Oddly everything still compiles. I guess the effect isn't seen until a project that needs to import the symbols comes along.

When I run the WebKitExportGenerator.exe it just crashes saying some dll's are missing (in particular MSVCR80.dll, shouldn't be searching for that anyways...wrong version. This leads to the actual exports file being completely empty.

Side Note: the same thing also happens when I tried to use my JavaScriptExportGenerator except it complained that pthreadVC2.dll was missing (although it seems to be there). The build actually does fail there though because jsc tries to import the symbols.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list