[Webkit-unassigned] [Bug 126133] Make CachedSVGDocument independent of CSS Filters
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Dec 23 12:43:51 PST 2013
https://bugs.webkit.org/show_bug.cgi?id=126133
Antti Koivisto <koivisto at iki.fi> changed:
What |Removed |Added
----------------------------------------------------------------------------
CC| |koivisto at iki.fi
--- Comment #12 from Antti Koivisto <koivisto at iki.fi> 2013-12-23 12:41:50 PST ---
(In reply to comment #6)
> > This class is just a pointer. I don't see why we are introducing it and making code more abstract. Also name seem off. It doesn't 'consume' anything.
>
> I think there is a misunderstanding. I do not try to fix the layer violation with this patch. Right now, CachedSVGDocumentReference can just be used by FilterOperation (specifically ReferencedFilterOperation). We have more situations like clip-path, SVG patterns and gradients that can be referenced from external resources as well. These operators need access to CachedSVGDocumentReference as well. See next paragraph...
I didn't say anything about layer violation (which is bad too). It just doesn't make sense to me to introduce a class that is nothing but a unique_ptr. You could replace the whole things with a typedef (not that you should). Usually something like this means that the design is off.
> > Why is ReferenceFilterOperation inheriting SVGDocumentConsumer instead of having one as a member?
>
> The abstraction SVGDocumentConsumer is used to access the CachedSVGDocumentReference. All inheriting classes are "consuming" CachedSVGDocumentReference that is why I think SVGDocumentConsumer is the right name.
That didn't really answer my question.
SVGDocumentConsumer does not do any consuming. It is a smart pointer without any additional functionality. Would you inherit from unique_ptr?
The SVG implementation is full of unnecessary abstractions which contribute to it being so hard to follow. Lets not add more.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list