[Webkit-unassigned] [Bug 125463] [GTK] Add API to allow setting the process model in WebKitWebContext

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 12 01:50:07 PST 2013


--- Comment #7 from Sergio Villar Senin <svillar at igalia.com>  2013-12-12 01:48:18 PST ---
(From update of attachment 218989)
View in context: https://bugs.webkit.org/attachment.cgi?id=218989&action=review

Overall looks good but we need unit tests for new API, check http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API

> Source/WebKit2/ChangeLog:7
> +

Short description needed here.

> Source/WebKit2/UIProcess/API/gtk/WebKitWebContext.cpp:843

s/is/which is/ ?

> Source/WebKit2/UIProcess/API/gtk/WebKitWebContext.cpp:852
> + *

In general I think the API description shouldn't be like this. We should explain the difference of having just one or multiple web processes instead of describing the benefits, Also one process per view is not totally correct, new processes are created for new browsing contexts, we might explain what it means in the docs as well.

> Source/WebKit2/UIProcess/API/gtk/WebKitWebContext.cpp:859
> +void webkit_web_context_set_process_model(WebKitWebContext* context, WebKitProcessModel process_model)

processModel you have to use CamelCase. You should use a different name for the local variable as well.

> Source/WebKit2/UIProcess/API/gtk/WebKitWebContext.h:78
> + *

OK so this is the description I was looking for. Then I guess you should link this somehow in the webkit_web_context_set_process_model() docs.

> Source/WebKit2/UIProcess/API/gtk/WebKitWebContext.h:234
> +                                                     WebKitProcessModel             process_model);


> Tools/MiniBrowser/gtk/main.c:244
> +    const gchar *minibrowser = g_getenv("MINIBROWSER_MULTIPROCESS");

It'd be nice to know if Mac is using something like this and use the same variable name.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list